Home My Page Projects Code Snippets Project Openings SML/NJ
Summary Activity Forums Tracker Lists Tasks Docs Surveys News SCM Files

SCM Repository

[smlnj] Diff of /config/releases/release-110.74/targets
ViewVC logotype

Diff of /config/releases/release-110.74/targets

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

sml/trunk/config/targets revision 1411, Tue Nov 4 17:50:53 2003 UTC config/trunk/targets revision 2587, Wed May 23 14:45:11 2007 UTC
# Line 15  Line 15 
15  # (The base system consisting of runtime, compiler, and basic libraries  # (The base system consisting of runtime, compiler, and basic libraries
16  # will always be built.)  # will always be built.)
17    
18  # unpack the source code for the SML/NJ compiler; this is not required,  # unpack the source code for everything (including for the SML/NJ compiler
19  # unless you are doing compiler hacking, but it may be interesting to look at.  # itself); this is not required,  unless you are doing compiler hacking,
20    # but it may be interesting to look at.
21  #  #
22  #request src-smlnj  #request src-smlnj
23    
24  # build ML-Yacc  # build new (Unicode-capable) ML-ULex
25    #
26    request ml-ulex
27    #
28    # Arrange for the .lex suffix to be recognized by CM as (new-style)
29    # ML-ULex input.
30    #   (Notice that you should NOT select this option even if you want to have
31    #    ml-ulex process legacy ml-lex input using the --ml-lex-mode option.)
32    # Since most existing projects have legacy .lex files, this should be
33    # kept off by default.
34    # WARNING: This is incompatible with ml-ulex-lex-ext!!
35    #request ml-ulex-lex-ext
36    #
37    # Register the "mllex" CM tool class in such a way that "legacy" ml-lex
38    # input is processed by "ml-ulex --ml-lex-mode".
39    #   (If you want the .lex extension to be mapped to the "mllex" class
40    #   and have that be processed by ml-ulex, you should request
41    #   ml-ulex-mllex-tool and ml-lex-lex-ext, but NOT ml-ulex-lex-ext.)
42    # WARNING: This is incompatible with ml-lex-mllex-tool!!
43    request ml-ulex-mllex-tool
44    
45    # build legacy ML-Lex
46    #
47    request ml-lex
48    #
49    # Register the "mllex" CM tool class in such a way that "legacy" ml-lex
50    # input is processed by the legacy ml-lex program.
51    # WARNING: This is incompatible with ml-ulex-mllex-tool!!
52    #request ml-lex-mllex-tool
53    #
54    # Arrange for the .lex suffix to be recognized by CM as legacy ml-lex input.
55    # This requires that either ml-lex-mllex-tool or ml-ulex-mllex-tool
56    # (but not both at the same time!) is installed.
57    # Since most existing projects have legacy .lex files, this should be
58    # kept on by default.
59    # WARNING: This is incompatible with ml-ulex-lex-ext!!
60    request ml-lex-lex-ext
61    
62    # build ML-Yacc (must come after ml-lex)
63  #  #
64  request ml-yacc  request ml-yacc
65    #
66    # Arrange for the .grm suffix to be recognized by CM as ML-Yacc input.
67    # Since .grm files in most existing project are ML-Yacc input, this should be
68    # kept on by default.
69    # WARNING: This is incompatible with ml-antlr-grm-ext!!
70    request ml-yacc-grm-ext
71    
72  # Always: install the pre-compiled ML-Yacc Library; this is necessary  # Always: install the pre-compiled ML-Yacc Library; this is necessary
73  # to use parsers produced by ML-Yacc, but also to bootstrap the system  # to use parsers produced by ML-Yacc, but also to bootstrap the system
74  # in the first place.  # in the first place.
75    
76    # build ML-Antlr
77    #
78    request ml-antlr
79    #
80    # Arrange for the .grm suffix to be recognized by CM as ML-Antlr input.
81    # Since .grm files in most existing project are ML-Yacc input, this should be
82    # kept off by default.
83    # WARNING: This is incompatible with ml-yacc-grm-ext!!
84    #request ml-antlr-grm-ext
85    
86  # build ML-Lex  # utility library for ml-antlr and ml-ulex
87  #  #
88  request ml-lex  request ml-lpt-lib
89    
90  # Always: install the pre-compiled SML/NJ Library (necessary to bootstrap).  # Always: install the pre-compiled SML/NJ Library (necessary to bootstrap).
91    
   
92  # build ML-Burg  # build ML-Burg
93  #  #
94  #request ml-burg  #request ml-burg
# Line 49  Line 102 
102  #  #
103  #request pgraph-util  #request pgraph-util
104    
105    # pre-compile and install "Trace-Debug-Profile" utility library
106    # (provides simple back-trace- and coverage facilities)
107    #
108    request tdp-util
109    
110  # pre-compile and install Concurrent ML, which is a library for message-passing  # pre-compile and install Concurrent ML, which is a library for message-passing
111  # concurrency.  # concurrency.
112  #  #
# Line 79  Line 137 
137  # "no longer foreign")  # "no longer foreign")
138  # This library is necessary to compile and/or run programs that use  # This library is necessary to compile and/or run programs that use
139  # the new FFI.  # the new FFI.
140  # This preview release currently works only under X86/Linux.  # This preview release currently works under X86/Linux, Sparc/Solaris,
141    # PPC/MacOSX, and X86/Win32.
142  #  #
143  #request ml-nlffi-lib  #request ml-nlffi-lib
144    
# Line 87  Line 146 
146  # the new "NLFFI" foreign function interface.  The tool generates ML  # the new "NLFFI" foreign function interface.  The tool generates ML
147  # glue code from C source code.  # glue code from C source code.
148  # (Requires ckit!)  # (Requires ckit!)
149  # This preview release currently works only under X86/Linux.  # This preview release currently works under X86/Linux, Sparc/Solaris,
150    # PPC/MacOSX, and X86/Win32.
151  #  #
152  #request ml-nlffigen  #request ml-nlffigen
153    
# Line 105  Line 165 
165  #  #
166  #request nowhere  #request nowhere
167    
168    # Build and install 'heap2asm' - an experimental component of
169    # a new facility for producing true stand-alone executables.
170    #request heap2asm
171    
172  # Note: autoloading is always enabled.  # Note: autoloading is always enabled.
173  #   In order to customize what is being pre-registered for autoloading  #   In order to customize what is being pre-registered for autoloading
174  #   edit file "preloads".  You should make sure that it contains at least  #   edit file "preloads".  You should make sure that it contains at least

Legend:
Removed from v.1411  
changed lines
  Added in v.2587

root@smlnj-gforge.cs.uchicago.edu
ViewVC Help
Powered by ViewVC 1.0.0